Inplex-sys
Inplex-sys5mo ago

"deno compile --no-terminal" is not working

I'm trying to compile a very simple file named main.ts
await Deno.writeTextFile('test.txt', 'Hello World');
await Deno.writeTextFile('test.txt', 'Hello World');
The problem is that after compiling and running the executable, it's doesn't work, it's showing nothing, but it doesn't work, but when i try to run the binary from a terminal it work. PS> deno compile --no-terminal -A main.ts Version: v8 12.1.285.6 typescript 5.3.3
3 Replies
Deno AI Helper
Deno AI Helper5mo ago
I wasn't able to find the answer to your question in the official Deno documentation. However, based on the information you've provided, I can offer some general advice. The --no-terminal flag is not a recognized option for deno compile. This could be the reason why the command is not working as expected. The correct usage of deno compile does not include a --no-terminal flag. You can compile your Deno project by simply using:
deno compile -A main.ts
deno compile -A main.ts
The -A flag gives all permissions, which is necessary for file system operations like writing to a file. Please note that this advice is not based on the Deno documentation, and I would advise you to double-check the accuracy of the advice given. If you continue to experience issues, you may want to explore the official Deno manual or seek support from the Deno community for further assistance.
ioB
ioB5mo ago
What operating system are you on?
Inplex-sys
Inplex-sys5mo ago
Windows