babakfp
babakfp7mo ago

`deno.disablePaths` doesn't work

Hi in .vscode\settings.json I have this:
{
"deno.disablePaths": ["**/kit", "./kit", "../kit", "/kit", "kit"],
}
{
"deno.disablePaths": ["**/kit", "./kit", "../kit", "/kit", "kit"],
}
I have a folder named kit inside the root folder, and I'm getting errors shown in the screenshot.
No description
1 Reply
Deno AI Helper
Deno AI Helper7mo ago
I'm sorry for the confusion, but according to the documentation, there is no deno.disablePaths setting. Instead, you should use deno.enablePaths to specify the paths where Deno should be enabled. If you want to enable Deno only for specific paths and not for others, you should list those specific paths in deno.enablePaths. Any paths not included in this list will not have Deno enabled. For example, if you want to enable Deno for all paths except for the kit directory, you should list all the other directories in your project in deno.enablePaths. Please note that the paths should be relative to the workspace root. If you're still having issues, please let me know! 🦕