D
Deno

help

Getting error trying to download NPM package

IIndustrial9/6/2023
Download https://registry.npmjs.org/@typescript-eslint/scope-manager/-/scope-manager-6.6.0.tgz
Download https://registry.npmjs.org/@typescript-eslint/types/-/types-6.6.0.tgz
Download https://registry.npmjs.org/@typescript-eslint/visitor-keys/-/visitor-keys-6.6.0.tgz
Download https://registry.npmjs.org/@typescript-eslint/parser/-/parser-6.6.0.tgz
Download https://registry.npmjs.org/@typescript-eslint/typescript-estree/-/typescript-estree-6.6.0.tgz
error: Uncaught Error: Trying to import ESM module: /home/tom/Code/code9/node/test-fp-ls/node_modules/.deno/ts-api-utils@1.0.2/node_modules/ts-api-utils/lib/index.js using require()
at Object.Module._extensions..js (internal:deno_node_loading/02_require.js:774:13)
at Module.load (internal:deno_node_loading/02_require.js:656:32)
at Function.Module._load (internal:deno_node_loading/02_require.js:513:12)
at Module.require (internal:deno_node_loading/02_require.js:678:19)
at require (internal:deno_node_loading/02_require.js:818:16)
at Object.<anonymous> (file:///home/tom/Code/code9/node/test-fp-ls/node_modules/.deno/@typescript-eslint+typescript-estree@6.6.0/node_modules/@typescript-eslint/typescript-estree/dist/convert-comments.js:27:30)
at Object.<anonymous> (file:///home/tom/Code/code9/node/test-fp-ls/node_modules/.deno/@typescript-eslint+typescript-estree@6.6.0/node_modules/@typescript-eslint/typescript-estree/dist/convert-comments.js:64:4)
at Module._compile (internal:deno_node_loading/02_require.js:745:34)
at Object.Module._extensions..js (internal:deno_node_loading/02_require.js:778:10)
at Module.load (internal:deno_node_loading/02_require.js:656:32)
Download https://registry.npmjs.org/@typescript-eslint/scope-manager/-/scope-manager-6.6.0.tgz
Download https://registry.npmjs.org/@typescript-eslint/types/-/types-6.6.0.tgz
Download https://registry.npmjs.org/@typescript-eslint/visitor-keys/-/visitor-keys-6.6.0.tgz
Download https://registry.npmjs.org/@typescript-eslint/parser/-/parser-6.6.0.tgz
Download https://registry.npmjs.org/@typescript-eslint/typescript-estree/-/typescript-estree-6.6.0.tgz
error: Uncaught Error: Trying to import ESM module: /home/tom/Code/code9/node/test-fp-ls/node_modules/.deno/ts-api-utils@1.0.2/node_modules/ts-api-utils/lib/index.js using require()
at Object.Module._extensions..js (internal:deno_node_loading/02_require.js:774:13)
at Module.load (internal:deno_node_loading/02_require.js:656:32)
at Function.Module._load (internal:deno_node_loading/02_require.js:513:12)
at Module.require (internal:deno_node_loading/02_require.js:678:19)
at require (internal:deno_node_loading/02_require.js:818:16)
at Object.<anonymous> (file:///home/tom/Code/code9/node/test-fp-ls/node_modules/.deno/@typescript-eslint+typescript-estree@6.6.0/node_modules/@typescript-eslint/typescript-estree/dist/convert-comments.js:27:30)
at Object.<anonymous> (file:///home/tom/Code/code9/node/test-fp-ls/node_modules/.deno/@typescript-eslint+typescript-estree@6.6.0/node_modules/@typescript-eslint/typescript-estree/dist/convert-comments.js:64:4)
at Module._compile (internal:deno_node_loading/02_require.js:745:34)
at Object.Module._extensions..js (internal:deno_node_loading/02_require.js:778:10)
at Module.load (internal:deno_node_loading/02_require.js:656:32)
The package I'm trying to install is @typescript-eslint/parser.

Looking for more? Join the community!